We've just launched our map. Add yourself by clicking here!

close

Omron temperature controller problems

This topic contains 12 replies, has 3 voices, and was last updated by  Stan 7 months ago.

2
Santiago León Romero Cabeza leonverde01

Omron temperature controller problems

20/04/2019 at 00:51

Im having problems with my Omron E5CWL temperature controller, I can’t find the way to make the temperature of my oven increases using the controller, I don’t know what could be wrong, I made the connection following schematics, the resistances are working fine, any information of how to use this controller will be very appreciated, thank you!
Estoy teniendo problemas con mi controlador de temperatura Omron E5CWL, no puedo hacer que la temperatura suba usando el controlador, no se que pueda estar mal, hice la conexión siguendos los esquemas y las resistencias funcionan bien cualquier información se agradeciria! Muchas gracias!

12 replies
2 subscribers
1 saved
2 likes
sort on most likes
warrior
20/04/2019 at 03:11
1

I don’t have that particular controller, but looking at the manual https://www.omron.com.vn/data_pdf/cat/e5csl_e5cwl_e5ewl_h167-e1_1_3_csm2643.pdf?id=3218, it appears similar to others. Does it display the correct PV temperature? Looks like there are models for different temperature sensors, do you have the right type sensor? Are you using an SSR and does your model match that output type? Are you detecting a voltage change on the output connection? If you post some symptoms it would be easier to help you diagnose the problem.
Good luck

starter
20/04/2019 at 20:42
1

@s2019 , thanks for the manual, already have it 😀
Displays the correct PV temperature.
I have a titanium  sensor, supports 1200 °C.
I have the exact SSR that the manual says (21 ma).
I think that maybe is a problem with the output, I put a tester on it, displays 0.00, I don’t know why is this happening, I don’t know if it is a electrical problem or a configuration problem. Hope this information can be a little more helpful, also, thanks for your reply! 😀 what a nice person!
Expecting for your answer!

warrior
20/04/2019 at 20:53
1

Just to confirm, do you have the -Q version used with SSRs? If you are getting 0.0 V on the output instead of 12, do you get that with the SSR disconnected? Is the output light on? Perhaps the SSR is faulty. Maybe check the SSR individually.

starter
21/04/2019 at 00:56
1

Thanks for the feedback, it’s been very clarifying, I have the RT1 version, so,  the output is 250 volts, too much for my SSR (smells like it burn) of 12 Ampers, and maybe the output is burned too, I have to ask an expert, another option is that I don’t understand completely how it works.
Any answer to that?
ImI gonna fix the output and get a new SSR (this time, the right one).
Oh, and thank you again, you are really saving my ass… 😂

warrior
21/04/2019 at 03:52
1

You can test if the output still works either with a AC voltmeter or a light bulb. If it is good, it is rated for 3 amps. I’m guessing that your oven uses more than that. There are SSR’s that can use the controller’s 250VAC output as control. If the controller is dead, just make sure the new controller and SSR match and you have plenty of margin on the SSR.

starter
23/04/2019 at 01:51
1

Yap, the oven uses 3,5 and 5,5 amps for working, now with the right SSR for 250VAC, and then of fixing the controller (the output burned out) I’ll try it and tell you how it works!
Thanks again!

starter
24/04/2019 at 04:15
0

Hi I am having similar problems. Can you provide more detail on how you solved?

I have tried two PID controllers. Both turn on and register temperature changes when I hold a flame to the thermocouple. Both click on when the set temp exceeds the present temp. However, neither provides any voltage to the SSR leads (measured with a multimeter set at 20V DC). For the second PID I confirmed it could turn on a light bulb from the SSR leads before I left the store. But when I got home, I can no longer light an LED or detect voltage. I confirmed the SSR will turn on when I connect it to a 9V battery and it will activate the heating element.

Could I be connecting it wrong? Could it be that my main voltage is 180V (rural Myanmar) but the PID controller is rated for 220V? Any ideas are appreciated.

Attachments:
warrior
24/04/2019 at 06:24
0

So, just to confirm. This specific model is supposed to provide a low voltage switching signal on 5 and 6, not a relay function itself. When you disconnect the leads from 5 and 6 you still get no voltage of any kind on 5 and 6 with set temp above present value, and the indicator light on.

starter
24/04/2019 at 07:04
0

I believe so. 5 and 6 should be low voltage based on the bulb that lit at the store when I bought it but I dont have a user manual (bought it on the street in Yangon). The relay function comes from the 40A SSR which is separate from the PID controller. Yes, when I disconnect from 5 and 6, the 5 and 6 leads still read 0V on the multimeter, despite the PID indicator light being on and SV above PV.

My first PID controller was a different model but had the same issue when I first connected everything.

warrior
24/04/2019 at 18:23
0

Sorry, it sounds discouraging.
I would try to diagnose the two controllers as stand alone at this point. For the 180v issue, since the controller takes very little power, maybe you can test it with a low power inverter (like the ones you can plug into a car) or a generator that does put out 220-250V. Someone near you may have one of these.

If you post the make/model of the two controllers maybe someone can find a manual or spec sheet.

As an example, the Omron manual posted above shows a 21ma max load on the 12v output but it has short circuit protection. If the test at 220-250V does not solve the problem, you may have to look inside to see if there obvious damage. @leonverde01 is repairing his damaged output maybe he can give more details.

starter
26/04/2019 at 06:40
0

Solved!

It turns out the controllers I have (RTC Rex-C700 and a TEL 72-8001B) do not have low voltage outputs.  Instead, there is an internal relay that just opens and closes according to the temperature.  I confirmed this by testing resistance and the controllers open and close the circuit at the output contacts.

The internal relays (3A) are not able to handle the heating elements.  Looks like I will have to step down voltage and invert to DC somehow to run a line through the internal relay to the SSR. Maybe it is time to take apart a USB phone charger!

Thanks for your help

warrior
26/04/2019 at 21:34
0

Is the output a switched 250VAC (3A max) or is it a passive switch? Looks like the Rex unit manual https://www.rkcinst.co.jp/english/pdf_manual/imnzc22e1.pdf says 250VAC 3A if you have that version. It may be easier to find an AC triggered SSR if possible. The phone charger may be slow to turn off unless you load the DC circuit.

I didn’t find a manual for your other controller but the partial spec sheets showed 10A or 30A capability. Not sure I trust that but you might be able to use it without and SSR. It was called an oven controller so maybe it is stand alone.

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Support our projects on Patreon so we can keep developing 💪